Troubleshoot Choppy Call Quality, Garbled Audio, or Dropped Calls

If you are experiencing poor call quality on your VoIP phones such as choppy lines, echo’s, delayed audio or garbled voices, this article will help you troubleshoot your issues.

The iProphet VoIP Phone System (Both Hosted and Premise based) runs on the VoIP platform.  This means your phone quality and user experience is dependant on your network configuration as well as your internet connection.  Note-IT vendors can learn from this post as well, so take notes.

ISSUE

VoIP Calls are experiencing bad audio quality

SYMPTOM

  • Echo’s
  • Choppy Calls
  • Voice Delay
  • Garbled Audio with Sounds

CAUSE

• Network congestion/delay leading to dropped packets (Local Area Network (LAN) related issues)
• Lack of bandwidth/unable to support simultaneous calls (Internet Service Provider (ISP) related issues/ Internet connection issues)
• Inconsistent ISP/throughput performance (ISP/ Internet connection issues)

RESOLUTION

1. Isolate the issue

• Are you the only one experiencing this or is it affecting other phones?
• Were there any recent changes to your local network? Changes may include the following:

○ Added a file server to the local network
○ Added/changed a network switch/router/firewall
○ Changed Internet Service Provider (ISP)

2. Run a speed test to evaluate your internet connection

Go to www.speedtest.net and perform 3-4 consecutive speed tests to check if the results are in line with your ISP’s internet connection package. Look for the following test results: 

• Download and upload speeds

○ Results should be no less than 75-80% of your provisioned speed
○ Results should be consistent
○ Contact your ISP to have your connection checked if your test results are inconsistent or is less than 75-80% of the speed in your internet plan

 

• Ping

○Reflects the overall delay in the network
○ Results should be under 60ms
○ Normal can range anywhere between 5ms to 48ms

 

3.  Contact your IT Administrator or your (ISP) to check on your internet connection if download/upload speeds are low or if ping is unusually high.

4. If possible, opt for a Business-level service agreement with your ISP. You may have to pay a bit more for the service but it will ensure that they provide to the level of performance you are paying for consistently.

5. Set your router to prioritize Voice-related traffic
Ensure that prioritization is configured for the voice-related traffic and minimum guaranteed bandwidth for this prioritized traffic is set on your router/firewall. 

In most Small Office Home Office (SOHO) routers, these QoS-related features are located in the QoS/Traffic Manager section of the router. Consult the manufacturer of your router for instructions on setting up the prioritization.  Google your make and model number.  The sticker on your router contains this information.